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Revised October 27, 2010 

This information is excerpted from the Vegas Pro user manual. For even more information about the software, you can download the 

manual from http://www.sonycreativesoftware.com/download/manuals. 


Closed Captioning 

Vegas® Pro software supports adding closed captions to video files and rendering those files as XDCAM HD and XDCAM HD422 MXF 
files. You can also add captions to video files and render as Windows Media Video for use in Windows Media Player. 

Adding closed captioning to video files 
Closed captions help make your video productions accessible to a wider audience. Closed captions are widely used by viewers who are 
deaf or hard of hearing, those who are learning to read, or who are learning a second language. 

Closed captions can be turned on or off by the viewer (unlike open captions, which are always displayed). Closed captions display 
spoken dialogue and sound effects as on-screen text. 

Notes: 

•	 Vegas Pro supports CEA608 captions and CEA708 containers containing CEA608 captions. CEA708 captioning is not supported. 

•	 When rendering to XDCAM HD/HD422, CEA608 data is uplifted to CEA708 format so that CEA608 and CEA708 captions are 

available when playing via HD SDI. CEA608 CC1 is uplifted to CEA708 Service 1, and CEA608 CC3 is uplifted to CEA708 Service 2.
 
Please note that caption positions can be slightly different after uplifting to CEA708.
 

•	 When you render to a format that does not support embedded captioning markers, an .scc file is created using the base name of 

the rendered media file.
 

Importing or rendering closed captions in an MXF file 

Importing closed captions from an MXF file 

Vegas Pro supports closed captioning embedded in XDCAM HD/XDCAM HD422 MXF.
 

When you add media to the timeline or Trimmer, embedded captioning markers are displayed as media markers.
 

Markers are aligned with the start of captioning for paint-on captions or with the display time for pop-up style captions.
 

When the captioning markers are read, Vegas Pro creates an .scc file in the media file’s folder using the same base name as the media file. 

The .scc file is used when you use the media in the future so the application doesn’t need to scan the media again.
 

When you’re finished editing your project, you can promote the embedded captioning markers to the timeline.
 

1.	 Select events with captions. 

2.	 From the Tools menu, choose Scripting, and then choose Promote Media Closed Captioning. 

The markers appear as command markers on the timeline, and you can move and edit the markers as needed: 
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Rendering captions in MXF files 

You can export captions in rendered media and in standalone .scc files. 

•	 When you render to XDCAM HD/XDCAM HD422 MXF formats, captioning markers are embedded in the media file. An .scc file is 
also created using the base name of the rendered media file. 

•	 When you render to a format that does not support embedded captioning markers, an .scc file is created using the base name of 
the rendered media file. 

Importing or rendering Line 21 closed captions 

Importing Line 21 captions 

Vegas Pro reads embedded Line 21 captions when you import a media file with a frame size of 720x486 pixels (or taller) and a frame rate 
of 29.97 fps. 

When you add media to the timeline or Trimmer, embedded captioning markers are displayed as media markers. 

Markers are aligned with the start of captioning for paint-on captions or with the display time for pop-up style captions.
 

When the captioning markers are read, Vegas Pro creates an .scc file in the media file’s folder using the same base name as the media file. 

The .scc file is used when you use the media in the future so the application doesn’t need to scan the media again.
 

When you’re finished editing your project, you can promote the embedded captioning markers to the timeline:
 

1.	 Select events with captions. 

2.	 From the Tools menu, choose Scripting, and then choose Promote Media Closed Captioning. 

The markers appear as command markers on the timeline, and you can move and edit the markers as needed: 

Rendering Line 21 captions 

Line 21 captions are supported during rendering for any media format when using a frame size of 720x486 pixels (or taller) and a frame 
rate of 29.97 fps. 
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Importing or printing captions when using HD SDI 

Importing closed captions over HD SDI 

Vegas Pro reads embedded VANC closed captioning when capturing video over HD SDI. 

•	 During capture, Vegas Pro creates an .scc file in the media file’s folder using the same base name as the captured file. 

•	 If capturing to XDCAM HD422 format, closed captions are also embedded in the captured file. 

Printing closed captions to tape over HD SDI 

When you print to tape over HD SDI, closed captions are included as VANC data. 

Importing closed captions from a closed captioning file 

If your media does not contain embedded captioning markers, you can import markers from an external file. The following file types are 
supported: 

•	 Scenarist Closed Caption (.scc) 

Tip: If an .scc file matches the media file name, the captions will be read automatically when you load a file. 

For example, if your video file is wildflowers.avi, naming your captioning file wildflowers.avi.scc will allow Vegas Pro to read the 
captions automatically. 

•	 RealPlayer Captioning Files (.rt) 

•	 SubRip Subtitles (.srt) 

•	 Windows Media Player Captioning Files (.smi) 

•	 Transcript or QuickTime Captioning Files (.txt) 

•	 CPC MacCaption Files (.mcc) 

Tip: If an .mcc file does not contain CEA608 captions, its CEA708 captions will be converted to CEA608 pop-up captions. Service 1 
captions will be imported as 608CC1 captions, and Service 2 captions will be imported as 608CC3 captions. 

•	 DVD Architect Subtitles (.sub) 

1.	 From the File menu, choose Import, and then choose Closed Captioning from the submenu. 

2.	 In the Open dialog, browse to the file you want to use and click Open. 

The markers appear as command markers on the timeline, and you can move and edit the markers as needed. 

Tip: Captioning markers will be placed according to the timecode in the captioning file. If needed, you can adjust marker 

positions by applying a timeline ruler offset before importing the closed captioning.
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Synchronizing captions with video 

After you import captions, you may need to adjust timing to synchronize the markers with your video. 

1.	 Use the procedure described earlier in this chapter to import captions. 

2.	 Position your video events as desired in the timeline. 

3.	 From the View menu, choose Edit Details to display the Edit Details window. 

4.	 From the Show drop-down list, choose Commands. Your captioning commands are now displayed in the Edit Details window. 

5.	 In the timeline, position the cursor where you want to start inserting captions. 

6.	 Select a row in the Edit Details list to select the first caption you want to insert. 

7. Click the Play button ( ) to start playback. 

8.	 When you’re ready to insert your first caption, press Ctrl+K. The first caption is inserted at the cursor position, the Position setting is 
updated, and the next caption is selected. 

9.	 Press Ctrl+K to insert each subsequent caption. 

Adding or editing closed caption markers on the timeline 

You can edit closed caption markers on the timeline to adjust caption start times, delete caption markers, edit their contents, or add new 
markers. 

•	 To add a new marker, click to position the cursor on the timeline and then choose Command from the Insert menu (or press C). 

Tip: To create a pop-on caption quickly, type your caption text in the Comment box in the Command Properties dialog. Caption 
markup is added automatically. You can use [BR] to indicate a line break. 

•	 To move a marker, drag the marker tag on the timeline. 

•	 To delete a marker, right-click it and choose Delete from the shortcut menu. 

•	 To edit a marker, double-click the marker tag. 

Use the Command Properties dialog to edit the marker. 

Item	 Description 
Command	 Choose 608CC1 for primary-language captions. 

Choose 608CC3 for secondary-language captions. 

Notes: 

•	 Vegas Pro also supports 608CC2 and 608CC4 commands for the CC2/CC4 channels. 

•	 When rendering to XDCAM HD/HD422, CEA608 data is uplifted to CEA708 format so 
that CEA608 and CEA708 captions are available when playing via HD SDI. CEA608 
CC1 is uplifted to CEA708 Service 1, and CEA608 CC3 is uplifted to CEA708 Service 2). 

Parameter	 Displays the marker’s captioning text. [BR] indicates a line break. 
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Item	 Description 
Comment	 Type closed caption control commands here. 

Commands must conform to standard caption markup, and command strings are case 
and space sensitive. For more information about captioning markup, see Captioning 
markup reference and examples on page 6. 

Tip: You can use your keyboard to create standard text and punctuation. To insert 
special characters and punctuation, use the Character Map (Start > All Programs > 
Accessories > System Tools > Character Map). 

For minor edits, you can ignore the markup and edit the displayed text.  If you change 
the length of the text, be aware of the following: 

• {R14In00Wh} means Row 14, Indent 00, White text. 

• Row (two digits) ranges from 01 to 15. 

• Indent (two digits) ranges from 00 to 28 but only in multiples of 4. 

• {TabOff1} means Tab offset 1. Possible values (one digit) are 1, 2, or 3. 

Important: For each row, indent (In) plus tab offset (TabOff) plus the number of 
content characters cannot exceed 32. 

Position	 Type the time you want the command to occur in your project. 
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Captioning markup reference and examples 

Pop-On Caption 

A pop-on caption is displayed on the screen as a single element and is cleared or replaced with a new caption. Pop-on captions are most 
often used for prerecorded captioning. 

{RCL}{ENM}{R14In00Wh}{TabOff1}First Row{R15In00Wh}{TabOff1}Second Row{EDM}{EOC} 

Tip: If you type captioning text in the Comment box of the Command Properties dialog and do not specify captioning markup, a 

pop-on caption is created.
 

Roll-Up Caption 

A roll-up caption scrolls onto and off the screen two or three lines at a time and is most often used for live captioning. 

{RU2}{CR}{R15In00Wh}{TabOff1}First Row 

—or— 

{RU3}{CR}{R14In00Wh}{TabOff1}First Row{R15In00Wh}{TabOff1}Second Row 

—or— 

{RU4}{CR}{R13In00Wh}{TabOff1}First Row{R14In00Wh}{TabOff1}Second Row{R15In00Wh}{TabOff1}Third Row 

Paint-On Caption 

A paint-on caption appears on screen one letter at a time and displayed like a pop-on caption. Paint-in captions are most often used at 
the beginning of a program. 

{RDC}{R14In04Wh}{TabOff3}First Row{R15In04Wh}{TabOff3}Second Row 

Captioning Markup 

Caption Markup Description Usage Notes 
{RCL} Resume Caption Loading Starts a pop-on caption. 

{RDC} Resume Direct Captioning Starts a paint-in caption. 

{RU2} Roll-Up Captions-2 Rows Starts a two-line roll-up caption. 

{RU3} Roll-Up Captions-3 Rows Starts a three-line roll-up caption. 

{RU4} Roll-Up Captions-4 Rows Starts a four-line roll-up caption. 

{EDM} Erase Displayed Memory Cleans the display. Required to remove roll-up and 
paint-on captions from the screen. 

{ENM} Erase Nondisplayed Memory Cleans buffered captions from memory. 

{EOC} End of Caption In pop-up captions, EOC ends the current caption 
and displays the next caption. 

{FlashOn} Flash On Causes the caption to blink until new foreground 
attributes are set. 

{TabOff1} Tab Offset 1 For each row, indent (In) plus tab offset (TabOff ) plus 
the number of content characters cannot exceed 32. 

{TabOff2} Tab Offset 2 

{TabOff3} Tab Offset 3 

{Backspace} Backspace Used for live captioning. 

{DelEndRow} Delete to End of Row Used for live captioning. 

{CR} Carriage Return 

{RyyWh} Row yy [00 to 15], White Text 

{RyyWhU} Row yy [00 to 15], White Underlined 

{RyyGr} Row yy [00 to 15], Green Text 

{RyyGrU} Row yy [00 to 15], Green Underlined 
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Caption Markup Description Usage Notes 
{RyyBl} Row yy [00 to 15], Blue Text 

{RyyBlU} Row yy [00 to 15], Blue Underlined 

{RyyCy} Row yy [00 to 15], Cyan Text 

{RyyCyU} Row yy [00 to 15], Cyan Underlined 

{RyyRd} Row yy [00 to 15], Red Text 

{RyyRdU} Row yy [00 to 15], Red Underlined 

{RyyYl} Row yy [00 to 15], Yellow Text 

{RyyYlU} Row yy [00 to 15], Yellow Underlined 

{RyyMa} Row yy [00 to 15], Magenta Text 

{RyyMaU} Row yy [00 to 15], Magenta Underlined 

{RyyWhI} Row yy [00 to 15], White Italics 

{RyyWhIU} Row yy [00 to 15], White Italics Underlined 

{RyyInxxWh} Row yy [00 to 15], Indent xx For each row, indent (In) plus tab offset (TabOff ) plus 
[00|04|08|12|16|20|24|28], White Text the number of content characters cannot exceed 32. 

{RyyInxxWhU} Row yy [00 to 15], Indent xx 
[00|04|08|12|16|20|24|28], White Underlined 

{WhTxt} White Text 

{WhUTxt} White Underlined 

{GrTxt} Green Text 

{GrUTxt} Green Underlined 

{BlTxt} Blue Text 

{BlUTxt} Blue Underlined 

{CyTxt} Cyan Text 

{CyUTxt} Cyan Underlined 

{RdTxt} Red Text 

{RdUTxt} Red Underlined 

{YlTxt} Yellow Text 

{YlUTxt} Yellow Underlined 

{MaTxt} Magenta Text 

{MaUTxt} Magenta Underlined 

{ITxt} Italicized Text 

{IUTxt} Italicized Underlined 

{BgWh} Background White 

{BgWhSemi} Background Semitransparent White 

{BgGr} Background Green 

{BgGrSemi} Background Semitransparent Green 

{BgBl} Background Blue 

{BgBlSemi} Background Semitransparent Blue 

{BgCy} Background Cyan 

{BgCySemi} Background Semitransparent Cyan 

{BgRd} Background Red 

{BgRdSemi} Background Semitransparent Red 

{BgYl} Background Yellow 

{BgYlSemi} Background Semitransparent Yellow 

{BgMa} Background Magenta 

{BgMaSemi} Background Semitransparent Magenta 

{BgBlk} Background Black 

{BgBlkSemi} Background Semitransparent Black 

{BgTran} Background Transparent 

{BlkTxt} Black Text 

{BlkUTxt} Black Underlined 
  ©2010 Sony Creative Software Inc. | 8215 Greenway Blvd. Suite 400 | Middleton, WI 53562 | 1.800.577.6642 | sonycreativesoftware.com <CHP#><CHP#> | 7 

http://www.sonycreativesoftware.com


 

  

  
 

 

   

 

 Caption Markup Description Usage Notes 
{StdCharSet} Standard Character Set You can use the character set commands to switch 

{DSzCharSet} 

{1PCharSet} 

Double Size Character Set 

First Private Character Set 

between character sets in your captions. For 
example, if you needed to display Korean characters 
in an English-captioned program, you could use 

{2PCharSet} Second Private Character Set {KORCharSet} to display Korean characters and 

{CHNCharset} 

{KORCharSet} 

People’s Republic of China Character Set 

Korean Character Set 

then use {StdCharSet} to switch back to English 
captions. 

{1RgCharSet} First Registered Character Set 

{TH} Time Holder Not used when creating new captions. 

When you’re working with existing captions, 
captioning data can be transferred ahead of the 
display time, and {TH} can be used to adjust the 
display time. 
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Displaying closed captions in the Video Preview or Trimmer window 

You can preview your captions by using overlays in the Video Preview window. 

Tip: Overlay settings from the Video Preview window are also applied to the video monitor in the Trimmer window. 

1.	 Click the down arrow next to the Overlays button ( ) and choose a setting from the menu to turn on the caption type that you 
want to preview. 

2.	 Play your project. 

Exporting closed captions 

Some Webcasting formats require that captions be saved in an external file. After creating your captions, you can export them to several 
formats. 

1.	 Create and edit your captions as described in this chapter. 

2.	 From the Tools menu, choose Scripting, and then choose a command from the submenu. 

Item Description 
Export Closed Captioning for 
DVD Architect 

Creates a subtitle (.sub) file that can be used by DVD Architect software. The .sub file 
contains timecode values and text that will be used to create subtitle events in DVD 
Architect. 

Export Closed Captioning for 
QuickTime 

Creates a text (.txt) and .smil file for each subtitle service. The text file contains the 
captions and formatting, and the .smil file contains information that defines how 
captions will display on the media file. 

The .smil file links to a .mov file that uses the same base name as your exported 
captions file by default. You can edit the file to refer to the desired media file name. 

Tip: If you’re using QuickTime Pro, you can create a QuickTime text track to embed 
captions in your video file. 

Export Closed Captioning for 
RealPlayer 

Export Closed Captioning for 
Windows Media Player 

Export Closed Captioning for 
YouTube 

Creates a RealText (.rt) and .smil file for each subtitle service. The RealText file contains 
the captions and formatting, and the .smil file contains information that defines how 
captions will display on the media file. 

The .smil file links to a .rm file that uses the same base name as your exported captions 
file by default. You can edit the file to refer to the desired media file name. 

Creates a .smi and .asx file for each subtitle service. The .smi file contains the captions 
and formatting, and the .asx file contains information that defines how captions will 
display on the media file. 

The .asx file links to a .wmv file that uses the same base name as your exported 
captions file by default. You can edit the file to refer to the desired media file name. 

Creates an .srt file that can be used for YouTube captions and by some DVD authoring 
software. 

For information about adding subtitles to your YouTube videos, please see 
http://www.youtube.com/t/captions_about. 

3. Use the Save dialog to specify a file name and folder for your captions file, and then click Save. 
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Editing multiple captions with the Edit Details window 

The Edit Details window allows you to see all of your project’s captions at once for quick editing. 

You can even edit multiple captions at once. For example, if you wanted to change your 608CC1 (primary language) captions to 608CC3 
(secondary language), perform the following steps. 

1.	 From the View menu, choose Edit Details to display the Edit Details window if it isn’t already visible. 

2.	 In the Edit Details window, choose Commands from the Show drop-down list. Your closed caption markers are displayed. 

3.	 Select the captions you want to edit: 

a.	 Hold Shift and click in the Command column for the first caption you want to change. 

b.	 Hold Shift and click in the Command column for the last caption you want to change.
 

All captions between the first- and last-selected rows are selected.
 

4.	 Right-click the Command column for any selected caption and choose Edit from the shortcut menu. 

5.	 Type a new value in the box — in this case, you’d type 608CC3 — and press Enter. 

All selected captions are changed to 608CC3. 
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Adding captions to Windows Media Video (WMV) files 
Captions makes your final video accessible to a wider audience. You can use text commands to add captions line-by-line to a Windows 
Media® Video (WMV) file, or for longer projects, you can add captioning from a script. 

Adding captions line-by-line 

1.	 Position the cursor where you want the caption text to appear. 

2.	 From the Insert menu, choose Command. The Command Properties dialog appears. 

3.	 From the Command drop-down list, choose Text. 

4.	 In the Parameter box, enter the closed captioning text you want to display. 

5.	 Click OK. 

6.	 Repeat steps 1-5 for each line of closed captioning text you want to add. 

7.	 Render your file in Windows Media Video format. For more information, see Rendering a project on page 389. 

Tip: Take steps to ensure that the captions are displayed when the video is played. For more information, see Displaying captions on 
page 13. 

Adding captions from a script 

Using a script to generate captions involves several steps. First, you must copy and paste the lines from the script into a spreadsheet. You 
can create the spreadsheet from scratch (using the steps that follow) or use the sample shell (Vegas Captioning Shell.txt) provided in the 
Sample Projects folder on the Vegas Pro application disc. You can open this tab-delimited shell with a spreadsheet application or, in the 
absence of a spreadsheet application, any text editor. 

When the spreadsheet is complete, you can copy and paste the lines into the Edit Details window. You can set the position for each line 
of captioning during playback. 

Creating a script spreadsheet 

1.	 Create a four-column, tab-delimited spreadsheet. 

2.	 In the first column, enter 00:00:00:00 in each of the cells as a placeholder. You will set the actual position of each line during 
playback. 

3.	 In the second column, enter TEXT in each of the cells to specify the command type. 

4.	 In the third column, enter the text that you want to display as a caption. Enter each line in its own cell. 

Tip: If you have a script, you can copy and paste individual lines into the cells. 
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5. In the fourth column, enter a label to identify your captions. An entry such as Line 001 can help you sort the captions once you 
paste them into your Vegas Pro project. 

Note: The final caption is displayed in the Microsoft® Windows Media® Player until the end of the video. To clear the final caption 
sooner, add a final command with no text (as shown above). 

Copying and pasting captions into Vegas Pro software 

1.	 Select the cells in the spreadsheet and copy them. 

2.	 Switch to Vegas Pro software and choose Edit Details from the View menu. The Edit Details window appears. 

3.	 From the Show drop-down list, choose Commands. 

4.	 Right-click the gray box in the upper-left corner and choose Paste from the shortcut menu. The spreadsheet data is pasted into the 
Edit Details window. 

5.	 Click the column header for the Comments column. This sorts the captions by line number. 

Right-click to paste the spreadsheet Click the Comments column header to
 
contents into the Edit Details window. sort the captions by line number.
 

Setting caption timing 

1.	 Position the cursor shortly before where you want the first caption to occur. 

2.	 Select the row for the first caption in the Edit Details window. 

3. Click the Play button ( ) to start playback. 

4.	 When playback reaches the place where the first caption should occur, press Ctrl+K. The first caption is inserted at the cursor 
position, updates the Position setting in the Edit Details window, and selects the next caption. 

5. Press Ctrl+K to insert each subsequent caption. 
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6.	 Render your file in Windows Media Video format. For more information, see Rendering a project on page 389. 

Displaying captions 

You can use one of two methods for displaying the captions when the video is played: 

•	 Instruct your audience to turn on captions: 

In Windows Media Player 8: from the View menu, choose Now Playing Tools, and then choose Captions from the submenu. 

In Windows Media Player 9 and 10: from the Play menu, choose Captions and Subtitles, and then choose On if Available from the 
submenu.
 

In Windows Media Player 11 and 12: from the Play menu, choose Lyrics, captions, and subtitles, and then choose On if available
 
from the submenu.
 

•	 Create an HTML page with the Windows Media Player embedded in it. See the online help for a sample HTML page. 
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